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Royal Haskoning Triwaco User's Manual

9.1  Introduction
Triplot is a Windows-based graphical viewing tool, included in the Triwaco package. Triplot can be called
from within the TriShell, but can also be used stand-alone.

Triplot enables the user to view, change, save and export in- and output of Triwaco groundwater models
both in plane view as in user defined cross-sections. The program displays a view with the layout of the
model grid. In- and output parameters can be loaded from the TriShell or TriPlot and parameter values may
be classified, contoured or used in an expression. Furthermore Triplot may display calculated groundwater
path lines, read from the binary output file of the particle-tracking   program   Trace. TriPlot also provides the
possibility to interactively start tracing of particle trajectories once a Trace configuration file has been defined
and loaded. How to carry out particle tracking in TriPlot is explained in chapter 11.

Geographical oriented information not allocated to the grid may be displayed as a background map. Various
formats are supported. The resulting view can be printed and the various quantities, including classes and
contours of the parameters loaded, may be exported and saved on disk. 
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9.2  Concepts and terms
The graphical presentation program TriPlot can be started from the various Triwaco data sets by
highlighting a parameter and subsequently choosing 'View' 'Adore' from the Parameter pull-down menu or by
selecting 'View Ado file' from the pop-up menu activated by the right-hand mouse button. The program will
start up opening a view or window, displaying the model's boundary, rivers and sources read from the grid
file. If no grid file exists or if the grid file does not correspond with the parameter file selected the program
displays a warning.

Starting TriPlot as a stand-alone program, the user should specify an existing grid file to be opened and
displayed.

A view consists of a number of layers, which contain information on the layout of the Finite Element or Finite
Difference grid and on parameter values. The grid properties are available in a grid file (grid.teo). Parameter
values should be allocated to the grid and are stored in one or more ado-files. An ado-file may contain one or
more adore sets: arrays of grid related data that result from parameter allocation. After loading a parameter in
TriPlot, its value may be displayed, classified or contoured.

Pathlines may be added to the view and are read from the unformatted output file of the particle-tracking
program Trace.

Additional information that is not related to the grid may be added to the view by means of a background
map. By now the following background file types are supported by Triplot: 

AutoCAD DXF files *.dxf
ARC/INFO ungenerate files *.ung
ArcView Shapefiles *.shp
Dawaco maps *.map; *.top
Windows Bitmap files *.bmp
TIFF files *.tif
GIF files *.gif
PCX files *.pcx
JPEG files *.jpg
Comma delimited files *.csv

It is possible to open several background maps at the same time. Each background map will be represented
by a separate layer in the view. How to open a background map.

Layers, items or properties of a view may be visible or hidden. Hidden properties are loaded but will not be
displayed in the view. 

A large number of items may be available during a TriPlot session, depending whether or not the appropriate
files have been loaded. Grid parameters are read from the Triwaco grid file (grid.teo). Input and output
parameters are read from the corresponding adore sets. The following table gives an overview of items that
may be available during a Triplot session. 

Here Bpar stands for any Boundary parameter, Rpar stands for any River parameter, Spar stands for any
Source parameter and Dpar for any distributed parameter, that is a parameter that should have a value at
each of the nodes of the Finite Element or Finite Difference Grid.

Item  or property File containing parameter
Grid parameters
Boundary Grid output file: Grid.teo
Boundary nodes Grid output file: Grid.teo
Boundary node numbers Grid output file: Grid.teo
Elements Grid output file: Grid.teo
Element numbers Grid output file: Grid.teo
Nodes Grid output file: Grid.teo
Node numbers Grid output file: Grid.teo
Rivers Grid output file: Grid.teo
River nodes Grid output file: Grid.teo
River node numbers Grid output file: Grid.teo
Sources Grid output file: Grid.teo
Source numbers Grid output file: Grid.teo
Node influence areas Grid output file: Grid.teo
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Item  or property File containing parameter
Cells ModFlow compatible grid output file: Grid.teo

Input and output parameters
Boundary classes: Bpar Boundary parameter file Bpar.ado
Boundary node values: Bpar Boundary parameter file Bpar.ado
River classes: Rpar River parameter file Rpar.ado
River node values: Rpar River parameter file Rpar.ado
Source labels: Spar Source parameter file Spar.ado
Classes: Dpar Distributed parameter file Dpar.ado
Contour map: Dpar Distributed parameter file Dpar.ado
Node labels: Dpar Distributed parameter file Dpar.ado

Miscellaneous
Background Map: C:\PATH\map.ext Specified 'Background ' map file
Streamlines: C:\PATH\trace.bin Binary TRACE output file 
Streamlines: C:\PATH\trace.tro TRACE result file 
Vector field Triplot vector file: velocity.vec
Section aa-aa' Triplot section file: aa-aa'.tps

For user specified sections and river sections
Profile: Dpar Distributed parameter file Dpar.ado
Profile: Rpar River parameter file Rpar.ado
Streamlines: C:\PATH\trace.bin Binary TRACE output file 

9.3  General settings
The general settings and properties window can be accessed selecting 'Properties' from the 'View' pull-down
menu, or right-mouse-button. The properties window contains two areas, listing the Visible items and the
Hidden items:

Selecting either  or  one can move an item from the list of hidden items to the list of
visible items and vice versa.

To change the appearance of an item or layer one may choose  after having selected the item. A
dialog-box or configuration window will appear and the user may change the settings of the item selected.
The type of dialog-box depends on the selected item. There are different configuration windows for lines,
points, labels, contours, classes, background files and streamlines. After having modified the settings the
user can save these to be added to the user's preferences or simply confirm them for the current TriPlot
session.
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9.4  Menu bar
The menu bar displays the following five commands: File, View, Param, Window and Help (See graphical
screen). Selecting one of these commands activates a pull-down menu with a number of sub-commands.
Some of the sub-commands may be activated by a shortcut-key (generally the Ctrl-key and another
character). Note that the Trace command, for pathline calculations, is described in chapter 11.

File

The File Commands pull-down
menu is being activated selecting
'File' from the menu bar. 

The pull-down menu has two
sections. The lower section lists
recently opened TriPlot files.
Selecting one of these files will
open the corresponding Triplot
session.

The upper section offers the sub-
commands the user can choose
from:

Open Open the file selected and display the information.
The following formats are supported:
- a valid Tesnet grid-file (*.teo, *.grd file)
- a previously saved Triplot view (*.tpp file)
- a Trace configuration file (*.cfg file)

Save Save the active view on disk for later use or for printing.
The following formats are supported:
- Triplot format (*.tpp file)
- Bitmap format (*.bmp file)

Export Export a layer (properties) of the active view. 
The following formats are supported:
- ArcView Shapefile format (*.shp file)
- ARC/Info ungenerated format (*.ung file)
- AutoCAD DXF format (*.dxf files)

Print Send the active view to the printing or plotting device.
The program opens a print properties dialog box to select:
- The printing device
- The area to be printed
- The scale of the map to be printed
- Whether or not to print a legend and scale bar

Exit Close all views and exit TriPlot
Shortcut-key for this command: Alt-F4.
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View
The View Commands pull-down menu is being
activated selecting 'View' from the menu bar. The
menu has four sections. 

The first section contains commands that enable
adjustment of the size and the area of the current
map on the screen (zooming and panning) and
that display general information on the grid or
enable the display of a legend and axes.

The second section enables the display of cross-
sections, streamline maps, velocity vectors,
background maps and calibration results.

The third section allows the user to measure
distances and areas, to find the location of
certain items and to inspect parameter values.

The last section allows the user to access the
properties window and to change the
configuration settings.

The View commands can be issued via this pull down menu or via the Toolbar. The pull-down menu offers
the following sub-commands the user can choose from:

Redraw Refreshes the screen.
Generally the program automatically refreshes the screen after issuing a command.

Zoom
In Enlarge the scale of the view by drawing a box.

Only part of the model area will be visible in the view.
Out Reduce the scale of the view by drawing a box.

A part or the entire model area will be visible in the view.
Reset Fit the extent of the active view in the current window.

The total model area will be visible in the view.
Pan Point and drag (a point of) the view to a new position. 

This command facilitates moving around the view while zoomed.
Grid Info Display information on the

Finite Element grid of the
active view. 
- Number of elements,
nodes, rivers etc.
- Minimum and maximum
coordinates and total model
area

Legend Display or hide the legend of the active view.

Axes Allows the user to select the
axes to be displayed,
choosing from Left, Top,
Right or Bottom. Default no
axes are being displayed. 
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Section
Create Generate and display a cross-section along a user-defined extent. The extent of the

section is defined by positioning the pointer and pressing the left-hand mouse button
several times. The section will be closed pressing the right-hand mouse button.

River Section Generate and display a cross-section along a river-stretch.
The program prompts for the river ID for which a section will be generated.

Streamline section Generate and display a cross-section along a streamline.
The program prompts for the path line ID for which a section will be generated.

Save Save a previously generated cross-section to a *.tps file
Load Load and display a saved cross-section in a new window.

Streamline map Display streamlines from a binary TRACE output file.
Vector field Display velocity vectors from file.
Background map Display background map from file. 

Several background file types are supported (such as: DXF, BMP, TIFF, GIF, PCX and
JPEG files, ArcView Shapefiles, Arc/Info ungenerate files and Dawaco maps).

Checkpoint Output Display calibration results from a checkpoint output file (*.cho).
A pop-up window will appear in which to specify the aquifer for which results have to be
displayed. 

Measure Display measurement tool and pop-up window. 
Pointing and pressing the left-hand mouse button at various locations causes the
program to compute and display the length of the line and the area enclosed within a
polygon with the line as perimeter. Pressing the right-hand mouse button ends this
action.

9  Visualisation and Post-Processing: TRIPLOT-8



Royal Haskoning Triwaco User's Manual

Find … Positions the pointer at the location of the selected item.
Select item and number: e.g. Nodes, 567.
One can choose from the following list of items:

Inspect Starts the inspection tool and pop-up window.
Pointing and pressing the left-hand mouse button at various locations causes the
program to compute and display coordinates, element and node numbers and values of
all loaded parameters for the selected location.

Properties Display the properties or general settings window.

Param
The Param Commands pull-down menu is
being activated selecting 'Param' from the
menu bar. 
The pull-down menu comprises commands that
enable various ways of displaying (distributed)
parameters, to retrieve general or detailed
information and to combine loaded parameters
to create new ones. 
The pull-down menu offers the following sub-
commands to choose from:

Load Import parameter values from file 
Expression Combine loaded parameters to generate a new parameter, using simple mathematical

expressions. The function is comparable to the expression allocator from the TriShell.
Save Save a parameter from the active view. Usually only meaningful for new parameters

generated with the 'Expression' command.
Contour Calculate and display contours for distributed parameters.
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Classify Assign parameter values to classes and display the classes of distributed parameters,
river parameters or boundary parameters.

Polygonize Joins adjacent node influence areas, for nodes having identical values, to larger
polygons. The resulting polygons are displayed.

Shade Generate and display a relief map of a distributed parameter.
Info Display general information on the parameter loaded. 

Statistical information and a histogram of parameter values are displayed in a pop-up
window.

Table Display a table of all loaded parameters of the active view.
This table may be copied to a spreadsheet to be processed. 
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Time
The Time Commands pull-down menu is being
activated selecting 'Time' from the menu bar.
The pull-down menu offers the following sub-
commands to choose from:

Starting date Converts timesteps into dates. Date can be displayed in the title.
Animate Generate and display an animation of contoured or classified transient parameters.
Time series Display time series in a graph of multiple output parameters (*.ado, *.flo, *.fzo).
Observations Display time series in a graph of multiple observed time series (*.csv).

Window
The Window Commands pull-down menu
is being activated selecting 'Window' from
the menu bar. 
The pull-down menu comprises
commands that enable various ways of
arranging the open windows. For some of
the commands a Shortcut-key is available.
The lower part of the pull-down menu
displays all windows available. The active
window is marked with an . 
The pull-down menu offers the following
sub-commands to choose from:

Duplicate Create a copy of the active view. The copy will have the same title, supplemented with a
sequence number. 

Cascade Display all active windows (or views), partly overlying each other.
Shortcut-key for this command: Shift-F5.

Tile Display all active windows (or views) completely filling the Triplot window area, each
view aside from the other.
Shortcut-key for this command: Shift-F4.

Tile horizontal Tile all active windows (or views), each view covering the width of the Triplot window
area. 

Tile vertical Tile all active windows (or views), each view covering the height of the Triplot window
area. 

Restore All Display all windows (or views), including those minimized.
Minimize All Minimize all windows (or views) and display icons only.
Close All Close all windows (or views) of the current Triplot session.
List of active windows or views in the current Triplot session

Help
The Help Commands pull-down menu is being
activated selecting 'Help' from the menu bar.
The pull-down menu offers the following sub-
commands to choose from:

Help Activates the Triplot help file indicated in Triplot.ini.
Shortcut-key for this command: F1.

About Triplot A pop-up window, showing the current version of Triplot.
About Royal Haskoning A pop-up window, showing general information on Royal Haskoning
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9.5  The toolbar
The toolbar offers the following possibilities that also may be addressed using commands from the menu bar.

Open and display an existing grid-file or a saved Triplot-view.
Equivalent to the command 'Open' from the 'File' pull-down menu.
Save the active view on disk for later use. The formats supported are:
- Triplot format (*.tpp file)
- Bitmap format (*.bmp file)
Equivalent to the command 'Save' from the 'File' pull-down menu.
Send the active view to the printing or plotting device.
Equivalent to the command 'Print' from the 'File' pull-down menu.
Enlarge the scale of the view by drawing a box.
Equivalent to the command 'Zoom' 'In' from the 'View' pull-down menu.
Reduce the scale of the view by drawing a box.
Equivalent to the command 'Zoom' 'Out' from the 'View' pull-down menu.
Point and drag (a point of) the view to a new position. This command facilitates moving around the
view while zoomed.
Equivalent to the command 'Pan' from the 'View' pull-down menu.
Fit the extent of the active view in the current window.
Equivalent to the command 'Zoom' 'Reset' from the 'View' pull-down menu.
Toggle between showing or hiding the legend of the active view.
Equivalent to the command 'Legend' from the 'View' pull-down menu.
Generate and display a cross-section along a user-defined extent.
The extent of the section is defined by positioning the pointer and pressing the left-hand mouse
button several times. The section will be closed pressing the right-hand mouse button.
Equivalent to the command 'Section' 'Create' from the 'View' pull-down menu.
Display measurement tool and pop-up window. 
Pointing and pressing the left-hand mouse button at various locations causes the program to
compute and display the length of the line and the area enclosed within the polygon with the line as
perimeter.
Pressing the right-hand mouse button ends this action.
Equivalent to the command 'Measure' from the 'View' pull-down menu.
Starts the inspection tool and pop-up window.
Pointing and pressing the left-hand mouse button at various locations causes the program to display
coordinates, element and node numbers and values of all loaded parameters for the selected
location. 
Equivalent to the command 'Inspect' from the 'View' pull-down menu.
Combine loaded parameters to generate a new parameter, using simple mathematical expressions.
The function is comparable to the expression allocator from the TriShell
Equivalent to the command 'Expression' from the 'Param' pull-down menu.
Generate and display an animation of contoured or classified transient parameters.
Equivalent to the command 'Time' from the 'Animate' pull-down menu.

9  Visualisation and Post-Processing: TRIPLOT-12



Royal Haskoning Triwaco User's Manual

9.6  How to ...

9.6.1  How to open a view
TriPlot will start and open a view or window, displaying the model's boundary, rivers and sources read from
the grid file whenever it is started from the various Triwaco data sets. TriPlot is started by highlighting a
parameter and subsequently choosing 'View' 'Adore' from the 'Parameter' pull-down menu or by selecting
'View Ado file' from the pop-up menu activated by the right-hand mouse button. 

Alternatively TriPlot may be used as a stand-alone program by selecting the Triplot-icon from the 'Program
Files\Triwaco'-folder. Starting Triplot as a stand-alone program, the user should open an existing grid file
first by selecting 'Open' from the 'File' pull-down menu or  from the toolbar. The user is prompted for a file
name, either a Triwaco grid file or a saved Triplot-view.

9.6.2  How to open background maps
A background map, to be displayed together with grid and parameter information, may be added to the view
selecting 'Background map' from the 'View' pull-down menu. The user is prompted for a file name; consistent
with one of the supported background map file types.

AutoCAD DXF files *.dxf
ARC/INFO ungenerate files *.ung
ArcView Shapefiles *.shp
Dawaco maps *.map; *.top
Windows Bitmap files *.bmp
TIFF files *.tif
GIF files *.gif
PCX files *.pcx
JPEG files *.jpg

While opening a bitmap as a background, TriPlot will display a dialog box, which can be used to scale the
bitmap to the edited map. The size of the pixels can be changed as well as the origin of the bitmap (the upper
left corner). Changing the width or the height independently from one another may result in a distorted
bitmap. By pressing the Save button,TriPlot will save a world-file (bitmap.tfw) with the actual values for pixel
size, origin and rotation shown in the dialog box. The next time TriPlot opens the bitmap (for example
bitmap.bmp) the values stored in the associated world file will be given as default values. If no world file is
present the width and height of the pixels are computed from the width and height of the area displayed in the
bitmap (in user units) and the number of pixels in horizontal and vertical direction. 

The world-file may also be edited or created using a text-editor. It is important that the worldfile (*.tfw) has the
same name as the bitmap file. Below an example of a dialog box and next to it the same data shown in the
tfw-file. 

The transparency of the background map can be changed in the dialog box. 
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9.6.3  How to display grid independent point values

Grid independent point values, to be displayed together with grid and parameter information, may be added
to the view selecting 'Background map' from the 'View' pull-down menu. The user is prompted for a file name
consistent with .csv file type. The following dialog box will appear.

9.6.4  How to add a parameter (*.ado)

To add a parameter to the view one should select 'Load' from the 'Param' pull-down menu. The user is
prompted for the name of a file containing parameter values in Adore format. Once this file is accepted a list
of (valid) parameters will be displayed. Selecting one of these parameters will add the parameter to the view.
More than one parameter may be selected.

Adding transient parameters works slightly different. An example is shown below. To add an entire timeseries
of a parameter select the parameter without extension. Seperate timesteps can be selected as well (select
parameter with extension TIME: .....).
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9.6.5  How to add a grid information as a parameter (*.teo)

Grid information, for instance node influence area, can be loaded as an paramter as well since it has the
standard adore file format. To add a grid parameter to the view one should select 'Load' from the 'Param'
pull-down menu. The user is prompted for the name of a file containing parameter values in Adore format. No
select All files (*.*) and select grid.teo froma grid data set. Once this file is accepted a list of (valid)
parameters will be displayed. Selecting one of these parameters will add the parameter to the view. More
than one paramter may be selected.

Note that, depending on the general settings, the parameter may remain invisible!

9.6.6  How to display parameter values
To display parameter values, plotted as labels, select 'Properties' from the 'View' pull-down menu or press the
right-hand mouse button, while pointing somewhere in the active view. The General settings or properties
pop-up window will appear. Parameter values may be displayed moving the items 'Node labels: PARNAME',
'Boundary node values: BNDPAR', 'River node values: RIVPAR' or 'Source labels: SRCPAR' from the
Hidden parameter list to the Visible parameter list ( ). 

9.6.7  How to retrieve parameter info
Statistical information and a histogram of parameter
values are displayed in a pop-up window selecting
'Info' from the 'Param' pull-down menu. The user is
prompted to select the parameter he wants
information about. The pop-up window displays the
parameter name, the file name, the number of values
in the Adore set, the minimum and maximum values
encountered and some more statistical information.
Moreover, a histogram of the parameter's value is
displayed. The histogram contains ten classes,
distributed evenly between the minimum and
maximum values encountered.
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9.6.8  How to contour parameter values
To display contours of parameter values select 'Contour' from the 'Param' pull-down menu. The user will be
prompted to select one of the parameters loaded. The program displays the contour configuration window to
define the levels to be contoured and the appearance of the contours. 

Within the configuration window the following areas may be distinguished to define various aspects of the
contour plot:

1. Smooth contours Option for smoothing contours. Three degrees of smoothing may be selected: Low,
Medium or High. If no smoothing is required clear the tick-box. ( ) 

2. Fill contours Select whether or not to apply a color fill. Two types of color fill are supported: Opaque
and Transparent. If no color fill is required clear the tick-box. ( )

3. Draw contours Select whether or not to accentuate
the computed contours with a drawn
line.

Selecting  displays a
pop-up window for the definition of
the color, width and style of the line
the contours are drawn with.
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4. Levels Define values and colors of the levels to be contoured.
The left part of the area displays the levels and colors selected.
The right part (4a) displays a number of commands for manipulating the selected
levels and colors. 

Level Displays a pop-up window for the definition of the start and stop value and the
increment of the parameter to be contoured.

Color Displays a pop-up window for selection of the color gradient to be used filling the area
between contours.

4a. Levels The commands in the right-hand side of the area are:
Classifier Defines the type of classifier to be

used for automatic generation of
contours or classes.
Four types of classifiers are
supported: Equidistant, select
Quantiles, select Equal Area and
Logarithmic.

Modify Changes the properties (Level and/or Color) of the contour selected in the list at the
left-hand side of this area.

Insert Adds a contour to the list of contours, between the selected one and the one above,
having an average value and intermediate color.

Delete Deletes the selected contour from the list at the left-hand side of the Levels-area.
Load Loads an earlier saved level-configuration file (*.lvl) with level and color definition.
Save Saves the actual level-configuration (values and colors of selected levels) in a file for

future use.
Defaults Restores the default settings for the contour map. Default settings are the use of the

'rainbow color gradient' and a restricted number of levels (equidistant, the number
depending on the difference between maximum and minimum value encountered).

Reverse Reverse coulour scheme
5. Label contours Option for adding labels to the contours. Both the number of contours to be labeled

(Label every 1, 2,…) and the number of labels for each contour (Density) may be
defined.

Font Displays a pop-up window for the definition of the appearance of the labels.

6. Label format Defines the way labels are displayed on screen.
7. Save settings Option for saving contour settings for future use. The settings are added to the user's

preferences in the General settings file.
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9.6.9  How to classify parameter values
To display parameter classes select 'Classify' from the 'Param' pull-down menu. The user will be prompted to
select one of the parameters loaded. The program displays the following configuration window to define the
levels for classification and the appearance of the classes. 

Within the configuration window the following areas may be distinguished to define various aspects of the
classified parameter plot:

1. Fill classes Select whether or not to apply a color fill. Two types of color fill are supported: Opaque and
Transparent. If no color fill is required clear the tick-box. ( )

2. Label classes Option for adding labels to the classes. Whenever the tick-box is checked all classes will
labeled.

Font Displays a pop-up window for the definition of the appearance of the labels; similar to the
one used for the contour labels.

3. Draw classes Select whether or not to accentuate the computed class-boundaries with a drawn line.
Line Style Displays a pop-up window for the definition of the color, width and style of the line the class-

boundaries are drawn with.
4. Levels Define class-boundaries (levels) and colors of the parameter to be classified.

The left part of the area displays the levels and colors selected. The right part (  4a  )   displays
a number of commands for manipulating the selected levels and colors, similar to those
used for contouring of parameter values. 

Level Displays a pop-up window for the definition of the start and stop value and the increment of
the parameter to be classified.

Color Displays a pop-up window for selection of the color gradient to be used filling the classes.
5. Save settings Option for saving classification settings for future use. The settings are added to the user's

preferences in the General settings file.
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9.6.10  How to create a relief map
To display a relief map of parameter values
select 'Shade' from the 'Param' pull-down menu.
The user will be prompted to select one of the
parameters loaded. The program displays the
following window to define the values for
Azimuth and Angle that define the appearance
or intensity of the shading. 

9.6.11  How to create new parameters (expression)
After having loaded one or more parameters the user may create a new parameter by combining these
parameters using the set of predefined mathematical expressions. To do so one has to select 'Expression' 
from the 'Param' pull-down menu or  from the toolbar. The program displays the following window to define
the new parameter and the expression to be used.

The left part of the window lists all parameters that are loaded in the active Triplot view. To the right the user
finds a list of predefined mathematical functions, a short description of the highlighted function and a list of
operators that can be used (presented by buttons in a tool-bar).

The lower part of the window allows the user to define a new parameter by entering a mathematical
expression. Double clicking on one of the parameters, a function or an operator adds the selected item to the
expression. The values for the parameter will be computed after confirmation of the expression entered.

9  Visualisation and Post-Processing: TRIPLOT-19



Royal Haskoning Triwaco User's Manual

9.6.12  How to display streamlines
To display a streamline map select 'Streamline map' from the 'View' pull-down menu. The user will be
prompted to select a Trace unformatted output file (*.bin). Subsequently the user will be prompted to enter a
Snap distance. Points belonging to the same streamline and lying within this distance from each other will be
omitted from the view.

The way the streamlines appear in the view can be modified through the general settings window that is
accessed by the commands 'Properties' from the 'View' pull-down menu.

The central area of the window (Info) displays information on the total number of streamlines loaded from the
streamline file and on the minimum and the maximum residence time encountered. Similar to the contour
settings window several areas may be distinguished to define the appearance of the streamlines.

1. Line color Option for defining the color of the streamlines. 
Streamline colors may vary with the layer the streamline crosses, with the travel time or with
the destination of the streamline. Also a single fixed color may be selected. The user
chooses one of the options by checking the appropriate box ( ). 

Line Style Displays a pop-up window for the definition of the color, width and style of the line the
streamlines are drawn with.

2. Draw Markers Option for adding time
markers to the streamlines.
Whenever the tick-box is
checked time markers will be
added to the streamlines. The
travel times for which markers
are added are those defined in
the ‘Times area’. The
appearance of the markers
depends on the font selected.
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Font Displays a pop-up window for the definition of the appearance of the markers. Selecting font
again will result in the well-known Font-style window. If one prefers marker symbols in stead
of the numbers one could select one of the ESRI-fonts.

3. Draw individual If the tick-box is checked ( ) each individual point of the calculated streamlines will be
displayed. 

4. Colors Define the class-boundaries and colors for the streamline parameter to be classified. 
The left part of the area displays the parameter values and colors selected. Depending on
the parameter selected one the following three labels will be displayed:

The right hand part (  4a  )   displays a number of commands for manipulating the selected
times and colors, similar to those used for contouring and classifying parameter values.

Time, Layers
or Dest

Displays a pop-up window for the definition of the start and stop value and the increment of
the parameter to be classified.

Color Displays a pop-up window for selection of the color gradient to be used to display the
classes.

5. Save Settings Option for saving classification settings for future use. The settings are added to the user's
preferences in the General settings file.

9.6.13  How to display results from an influence area simulation (*.tro)

Results from an influence area simulation is stored in an adore type format file. To add a parameter to the
view one should select 'Load' from the 'Param' pull-down menu. The user is prompted for the name of a file
containing parameter values in Adore format. No select All files (*.tro) and select grid.teo froma grid data set.
Once this file is accepted a list of (valid) parameters will be displayed (see below). Selecting one of these
parameters will add the parameter to the view. More than one parameter may be selected.

Note that, depending on the general settings, the parameter may remain invisible!

9.6.14  How to execute streamline calculations
How to execute streamline calculations in TriPlot is explained in Chapter 11 Calculation of pathlines and
particle tracking;   Trace  .

9.6.15  How to create a cross-section
Triplot recognises the following types of cross-sections: the user defined cross-section, the river section and
the streamline section. A cross-section consists of a line, defined by two or more points. Aquifers and
aquitards will be displayed once the corresponding parameters (RLi and THi) have been loaded. In a cross-
section hydrogeological parameters for the various aquifers and aquitards may be contoured or classified,
groundwater heads may be plotted and streamlines may be projected on the plane of the (vertical) cross-
section.
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User defined cross-section
To create a user defined cross-section select 'Section' 'Create' from the 'View' pull-down menu or  from
the tool-bar. A special (pencil-like) cursor appears on the screen and the user defines the section by drawing
a line, pressing the left-hand mouse button to start the line and to define intermediate points and pressing the
right-hand mouse button to define the end point of the section. The user is prompted to enter a section name.

Confirming the name, TriPlot opens a new window to display the cross-section. The parameters from the
original window that define the hydrogeological layers will automatically be added to the cross-section, as will
be any streamline map present in the original window. The program also displays the section properties
window so the user can select the layers to be displayed in the cross-section.

Whenever the parameter RLi and THi are loaded the program will create and add the following items to the
view:
Layer: Aquifer i Between RLi and THi
Layer: Aquitard i Between THi and RLi+1
Layer: Top System Between TT and RL1

Items or parameters that are not required can be
moved from the list of visible items to the list of
hidden items. 
The appearance of the items can be adjusted and
one can use vertical exaggeration.

Selecting  the configuration window appears
and the user can modify the appearance of the
parameter selected.
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New parameters may be added to the cross section
selecting 'Profile' from the 'Parameter' pull-down
menu. A list of the parameters that have been
loaded appears to choose from.

A parameter that has not been loaded yet can be
added to the cross-section selecting 'Load' from the
'Parameter' pull-down menu.

After having made a selection of layers, parameters and streamlines the cross-section will be displayed.

Once a section has been defined the
section can be saved from the properties
window of the main Triplot view (e.g. the
plane view Triplot starts with). To save a
section to a *.tps file select 'Section'
'Save …' from the 'View' pull-down
menu. The program prompts for a name
and for the section to be saved (if there
is more than one section defined in the
view).

To load a previously saved cross-section
select 'Section' 'Load …' from the 'View'
pull-down menu. The program prompt
for a *.tps file to open and will display the
saved cross-section in a new window.

The user-defined cross-section will be 
displayed in plane view by a (red) line, 
with the section's name next to it.

Selecting  while highlighting the section in the visible items list the program displays the configuration
window, which allows the user to change the appearance of the section in plane view and to save these
settings.

River section
To create a river section select 'Section' 'River section'
from the 'View' pull-down menu. The user is prompted
to enter a river number. In addition to the distributed
parameters also river parameters may be added to the
view. The selection of parameters to add to the river-
section is the same as with the user defined cross-
section.
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Streamline section
To create a streamline section select 'Section'
'Streamline section' from the 'View' pull-down menu.
The user is prompted to select the streamline number
from a pop-up window. This window displays
information on the selected streamline while this line is
flashing in the TriPlot view.

Note River sections or streamline sections can NOT
be saved to a separate *.tps file.

9.6.16  How to add axes to an area view or cross-section
To add axes to an area view or cross-section select ''Axes' from the 'View' pull-down menu. The user is
prompted to select the axes from a pop-up window. The result in a cross-section may look something like
this.

9.6.17  How to export a parameter map
To export a parameter map, either defined by classes or by contours, one should select 'Export' from the
'File' pull-down menu. The user is prompted for a file name. The following file types are supported by Triplot
for saving a parameter map: the ARC/Info ungenerated file format, that can also be read by DigEdit, the
ArcView shape file format and the AutoCAD DXF file format.
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Choosing either one of these formats and supplying a file name, the program prompts for the parameter to be
exported. Only for export to Arc/Info ungenerated format some additional export options may be selected. For
export to an ArcView shape file or an AutoCAD DXF file no additional information is needed.

ArcView shape file

ARC/Info ungenerated file
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AutoCAD DXF file

9.6.18  How to create an animation
An animation can be created provided that a transient parameters or transient simulation results are loaded.
To create an animation first create an contour or classified map of the parameter used in the animation. Then

select 'Time', 'Animate' from the menu bar (or simply ). The following dialog box will appear.

Specify the start time, stop time, time step or number of steps. Delay is used to set the delay time for the
frames. Close the dialog box by OK. To start the animation push the play button in the following box. One
may also use the time bar to show individual frames.

To create a title and to insert dates in each frame first define the start time by 'Time', 'Starting date' . One is
prompted to define date and starting time. Next step is to open the properties window which can be accessed

selecting 'Properties' from the 'View' pull-down menu, or right-mouse-button. Select . The following
dialog box will appear. Check 'Show title'. By adding title to the view the date progress is also added to the
view. The title will appear at the bottom left and the time progress at the bottom right (often behind the frame
dialog box).
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An animation may also be saved to disk by selecting output to disk. Various file compression formats are
available.

Note that, in some cases the transient parameter may exceed the standard windows filesize. For these
instances a adore splitting tool is available in the triwaco3\tools directory (adosplitter).

9.6.19  How to create time series (graphs)

Time series from output parameters (*.ado, *.flo, *.fzo)
A time series graph can be created provided that a transient parameters or transient simulation results are
loaded. To create a time series graph 'Time', 'Time series' from the menu bar. Select parameters for time
series. The time series for each selected parameter is loaded from the transient file. Then point and select
the location to create the time series graph. To create another graph for another location simply point and
select that location. The current time series graph will be refreshed.

Time series from observed time series (*.csv)
Added to a time series graph or as a seperate graph time series from observation point can be visualised. To
add or create a time series from observed heads select 'Observations' from the pulldown menu. Select the
csv file which at least should contain X-coordinat, Y-coordinate, Name, Time and Value as shown below. A
CSV file can easily be created in Excel or other spreadsheet program. Note that is has to comma seperated
and not ; seperated.

The program opens a pop up window where each column from the observations file can be assigned. Once
loaded the observations points are displayed in the model area (similar as for the calib.chi). To display the
time series select 'Time', 'Time series' from the menu bar. Select parameters for time series. The time series
for each selected parameter is loaded (either from the transient output file or fro observations). Then point
and select the location to create the time series graph. The time series of an observation point will only be
displayed when a point is selected near to an observation point. To create another graph for another location
simply point and select that location. The current time series graph will be refreshed.
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 X,Y,Name,Aquifer,Time,Value

 148158.6,408848.1,000001A00,0,0.00E+00,1.53E+00,

 148158.6,408848.1,000001A00,0,5.00E-01,1.49E+00,

 148158.6,408848.1,000001A00,0,1.49E+00,1.48E+00,

 148158.6,408848.1,000001A00,0,3.44E+00,1.47E+00,

 ...
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The appearance of time series can easily be changed by right-click mouse which opens a menu. One may
change the thickness of the lines and change the time of markers.

Note that, more than one time series graphs can be opened with different parameters.
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9.6.20  How to save a triplot session
A Triplot view may consist of one or more windows, of which at least one contains the model area in plane
view.

The view, with all associated settings, may be saved in a so-called Triplot project file (*.tpp). Selecting 'Save'
from the 'File' pull-down menu or  from the tool-bar will cause the program to prompt for a file name.
Having supplied this information the view is saved for future use in the selected *.tpp file. A saved view can
be opened by Triplot selecting 'Open' from the 'File' pull-down menu or  from the tool-bar.
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